Solucionar erro innodb_strict_mode no Plesk Migrator

Tecnologia
Publicado em: 28 de junho de 2022 - Visto 188 Vezes.

Solucionar erro innodb_strict_mode no Plesk Migrator

  • #SHARE / COMPARTILHE:
  • Compartilhe no Whatsapp
  • Compartilhe no facebook
  • Compartilhe no Twitter
  • Compartilhe no PINTEREST
READ IN:
  • PortuguêsPortuguês
  • EnglishEnglish
  • Sobre o erro innodb_strict_mode no Plesk Migrator: O Plesk Migrator, é uma ferramenta muito útil para aqueles que utilizam o painel Plesk para gerenciar sua hospedagem de sites.

    As vezes, durante o gerenciamento do seu painel de hospedagem, pode existir a necessidade de migrar de um servidor para outro e a extensão Plesk Migrator, realiza essa função de maneira rápida e fácil em poucos cliques.

    O problema é que durante o processo de migração, podem acontecer avisos de erros e incompatibilidades como a que eu mostro a seguir.

    Um dos erros mais comuns é o innodb_strict_mode, que acontece quando a migração da origem, hospedada está com uma versão anterior do InnoDB (InnoDB 5.6 ou abaixo).

    No InnoDB 5.6 (ambos no MySQL 5.6 e MariaDB 10.0/10.1) o servidor tem a variável innodb_strict_mode=0 por padrão.
    Assim, você pode criar uma tabela com a opção ROW_FORMAT errada e o aviso será relatado.
    No InnoDB 5.7 (ambos no MySQL 5.7 e MariaDB 10.2) o servidor tem a variável innodb_strict_mode=1 por padrão.

    Com isso, a migração da origem, hospedada com a versão anterior do InnoDB não será possível para o destino com a versão atual do InnoDB e um erro será emitido se innodb_strict_mode for definido como padrão.

    Veja o aviso no painel sobre esse abaixo:

    In InnoDB 5.6 (both in MySQL 5.6 and MariaDB 10.0/10.1) server has variable innodb_strict_mode=0 by default.
    So you can create table with wrong ROW_FORMAT option and warning will be reported.
    In InnoDB 5.7 (both in MySQL 5.7 and MariaDB 10.2) server has variable innodb_strict_mode=1 by default.
    Migration from source, hosted with previous version of InnoDB will not be possible to target
    with current version of InnoDB and error will be issued if innodb_strict_mode is set to default.
    Set variable innodb_strict_mode to OFF on target to avoid the migration errors.
    Here is the link describing the problem
    https://jira.mariadb.org/browse/MDEV-11305
    Mensagem de Erro innodb_strict_mode
    Mensagem de Erro innodb_strict_mode

    Como corrigir o erro innodb_strict_mode:

    Para corrigir esse erro, basta você definir a variável innodb_strict_mode como “OFF” no destino para evitar erros de migração.

    Para isso, basta seguir os seguintes passos:

    1 – Acesse o WebAdmin (phpMyAdmin) do seu servidor;

    2 – Vá até o SQL para executar consulta SQL no servidor;

    3 – Para mostrar como estão essas variáveis atualmente realize a seguinte consulta: show variables like ‘%strict%’;

    4 – Para definir o innodb_strict_mode como “OFF”, realize a seguinte consulta: set global innodb_strict_mode = OFF;

    5 – Agora, para ter certeza de que a variável mudou, realize novamente a consulta: show variables like ‘%strict%’;

    Pronto, sua variável já está definida como OFF e a migração pode acontecer com sucesso.

    Sobre o autor:

    Esse post foi publicado em 28 de junho de 2022 por Alx Coimbra.
    Blogueiro desde 2009 - Programador - Amante da tecnologia e internet - Escritor e Editor dos sites: Portal10.Info e PortalParalelo.Com
    Tags: , #SHARE / COMPARTILHE:

    Subscribe
    Notify of
    guest
    0 Comentários
    Inline Feedbacks
    View all comments